DegreeWorks Outage
Incident Report for Eastern Oregon University
Resolved
This incident has been resolved.
Posted 11 months ago. Jun 28, 2017 - 07:50 PDT
Monitoring
DegreeWorks is back online, it is being monitored for further issues.
Posted 11 months ago. Jun 26, 2017 - 08:43 PDT
Investigating
The DegreeWorks server is currently experiencing an outage. The server is currently not allowing anyone to log on. We hope to have the problem resolved soon.
Posted 11 months ago. Jun 26, 2017 - 08:18 PDT