DegreeWorks Outage
Incident Report for Eastern Oregon University
Resolved
Ellucian has determined the cause of the issue and implemented a fix, DegreeWorks is now operational again.
Posted 10 months ago. Jul 12, 2018 - 11:10 PDT
Investigating
DegreeWorks is temporarily down, the Degreeworks audit will not load. Ellucian has been notified and they are investigating the cause of the issue.
Posted 10 months ago. Jul 12, 2018 - 09:18 PDT
This incident affected: Applications (DegreeWorks).