DegreeWorks Outage
Incident Report for Eastern Oregon University
Resolved
We believe we have DegreeWorks up and working again but will continue to monitor it. If you continue to have issues please submit a ticket to infosys@eou.edu and we will be happy to assist.
Posted Feb 18, 2020 - 13:16 PST
Investigating
We are aware of a DegreeWorks outage and are working on finding and correcting the issue.
Posted Feb 18, 2020 - 12:37 PST
This incident affected: Applications (DegreeWorks).