FAST Finance and Financial Aid
Incident Report for Eastern Oregon University
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 07:55 PDT
Update
Hello,

Fast Finance completed in 2 hours and 41 minutes. Fast FinAid completed in 43 minutes. Refresh is back to normal.
Posted Jun 10, 2021 - 07:54 PDT
Identified
The Fast Financial Aid and Finance modules are experiencing refresh difficulties. IT is working with Fast Support on this. We believe we have found a way to resolve the issue and are working on implementing it.
Please make sure to check the "Data as of" indicator in the upper right hand corner when running any Fast reports to determine how recent the data you will receive is.
Posted Jun 09, 2021 - 10:05 PDT
This incident affected: Applications (Millennium Fast).