Astra Sync - Down
Incident Report for Eastern Oregon University
Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 09:00 PDT
Identified
Waiting for Adastra to assign tech for troubleshooting.
Posted Apr 01, 2022 - 08:00 PDT
This incident affected: Applications (AdAstra Scheduling).