College Scheduler Down
Incident Report for Eastern Oregon University
Resolved
Hello,

The issue appears to be resolved and is being reported as resolved by Civitas, if you encounter any issues please contact IT at infosys@eou.edu and we will be happy to help.

Thanks,
EOU IT
Posted Nov 02, 2020 - 15:47 PST
Investigating
Hello,

College Scheduler available within Mountie Hub is currently down. The company Civitas Learning, owner of College Scheduler, is aware and is currently investigating the issue. We are will update this incident as soon as we know more, or the issue has been resolved. Mountie Hub registration remains functional so students may continue to use it to register for classes.

Thank you for your patience,
EOU IT
Posted Nov 02, 2020 - 12:16 PST
This incident affected: Applications (Mountie Hub (Webster)).