Mountie Hub Personal Information screen unavailable.
Incident Report for Eastern Oregon University
Resolved
We were able to restore the Personal Information Screen within Mountie Hub last night and it has remained up so we believe this issue to be resolved.
Posted May 15, 2020 - 09:31 PDT
Investigating
We are currently looking into why the Personal Information Screen within Mountie Hub is down. We are working with our vendor on this and will update as soon as we have it corrected.

Currently this is the only screen within Mountie Hub that is unavailable and all other screens should be working.
Posted May 14, 2020 - 11:03 PDT
This incident affected: Applications (Mountie Hub (Webster)).