Additional Banner Downtime Sunday
Incident Report for Eastern Oregon University
Resolved
Scheduled Banner Maintenance has been completed.
Posted 20 days ago. Oct 01, 2017 - 18:03 PDT
Identified
This is an extension of the previous outage for Banner.
Scheduled maintenance is still ongoing.
Posted 20 days ago. Oct 01, 2017 - 11:46 PDT