Salesforce believes they have resolved the issue and are monitoring to make sure it will not reoccur. EOU IT tickets that were submitted yesterday (June 26th) have started coming in to the IT Ticketing System.
Due to staffing shortages and Mountaineer Day, you may still experience delays in receiving support for submitted tickets. EOU IT thanks you for your patience as we work through the backlogged requests.
Posted Jun 27, 2025 - 09:03 PDT
Update
Tickets and responses submitted directly through the IT Support Portal are not affected by this issue. If your support request is urgent, please submit a ticket through the Support Portal here: https://support.eou.edu/
Posted Jun 26, 2025 - 16:51 PDT
Identified
An upstream Salesforce issue is causing the EOU IT Ticketing System to experience major delays with receiving new tickets or ticket responses sent through email. Users may experience delays in receiving EOU IT support until the issue is resolved.
Posted Jun 26, 2025 - 16:21 PDT
This incident affected: Servers & Services (IT Ticketing System).