EOU has confirmed the issue is intermittent. Some requests are being handled normally while some are failing over and causing the limits to be reached. Please continue to use the alternate options provided if you are affected.
Posted Aug 01, 2025 - 10:49 PDT
Investigating
When prompted for MFA to verify your login to the my.EOU Portal using the SMS option (a code is sent to your phone via text message), the normal service is failing and falling to a backup that can only handle a small amount of requests.
If you get this message when trying to sign in: "You have reached the limit of sms requests, please try again later." These are your options: - Wait at least 10 minutes and then try again, although it could take up to an hour for the limit to reset. - Use a different authentication method if you have one configured on your account, like Okta Verify or Google Authenticator. Click "Verify with something else". - Use the Recovery App at https://recovery.eou.edu to generate a temp OTP code.
We are investigating the issue and will provide updates when we know more.
Posted Aug 01, 2025 - 10:27 PDT
This incident affected: Servers & Services (Authentication / Log-On Services).