Degreeworks outage
Incident Report for Eastern Oregon University
Resolved
This incident has been resolved.
Posted Nov 30, 2023 - 09:10 PST
Monitoring
The Ellucian Cloud team has identified a potential solution and implemented the necessary corrective actions. We are requesting that you please validate that the condition no longer exists and report any issues immediately.
Posted Nov 28, 2023 - 09:59 PST
Investigating
We are currently investigating this issue.
Posted Nov 28, 2023 - 06:15 PST
This incident affected: Applications (DegreeWorks).