Salesforce Outage
Incident Report for Eastern Oregon University
Resolved
Salesforce has informed us that this was an issue on their end and they have solved it, Salesforce is back to normal.
Posted May 12, 2021 - 07:25 PDT
Investigating
Currently, Salesforce has been down for at least 30 minutes, we are not aware of any updates or maintenance schedule, we are currently investigating what was the cause and seems that this is affecting other organization.
Posted May 11, 2021 - 15:30 PDT
This incident affected: Applications (SalesForce (CRM)) and Servers & Services (Informatica).