FAST Finance Reporting - Unstable
Incident Report for Eastern Oregon University
Resolved
Fast Finance is currently up and running again.
Posted about 1 month ago. Mar 12, 2019 - 13:37 PDT
Investigating
Hello,
Fast Finance Reporting is currently having issues loading, and running reports. We are currently looking into the issue, and will monitor the application for changes.
Posted about 1 month ago. Mar 12, 2019 - 12:04 PDT
This incident affected: Applications (Millennium Fast).