Phone system outage

Incident Report for Eastern Oregon University

Resolved

Phones should now be working normally. If you are still experiencing issues with your phone, please submit an IT Help Desk ticket: https://eou.my.site.com/s/article/contact-it-help-desk
Posted Sep 03, 2025 - 19:04 PDT

Identified

NocTel has restored the downed server. Desk phones will require a restart in order to restore functionality. IT will slowly go through and restart phones over the network.
Posted Sep 03, 2025 - 14:52 PDT

Investigating

The campus telephone service provider, NocTel, is experiencing a partial outage with some of their servers.
Posted Sep 03, 2025 - 11:26 PDT
This incident affected: Network (Telephone).