FAST Finance Reporting

Incident Report for Eastern Oregon University

Monitoring

We believe the issue causing options to not be displayed in the filters to be resolved, and the filters should be operating normally now.
We believe the issue causing reports to disappear from users' view has been resolved, which should prevent this from occurring again. However, we are still working on restoring the permissions that were removed by the initial problem occurring, meaning users may not see the reports back in their menus yet. Barring any unforeseen events, we will provide a final update to this incident when we believe those permissions to be restored.
Posted May 28, 2026 - 10:24 PDT

Update

We are continuing to investigate the FAST Finance issue. It turned out that FAST had not made any changes to report access, and this was a result of a problem within the system. We believe the cause of the reports going missing has been identified and resolved such that no further changes will occur, but we are still working on trying to restore access.
FAST and EOU InfoSys are still seeking a definite cause of the filter problem.
Posted May 27, 2026 - 17:10 PDT

Investigating

EOU's FAST reporting system is experiencing a partial outage (degraded performance and unavailability of some reports).
We believe the issue to be contained to the Finance Module.

Initially, we received reports of a problem with some of the baseline filters (FUND and ORG for sure) not populating with data appropriately. Because this was a baseline issue, EOU IT InfoSys had to reach out to FAST Customer Support. In the process of troubleshooting the issue it seems FAST has had to temporarily adjust some permissions, which is causing some reports to become unavailable to some users. FAST is working to correct this issue, but at this time the reason for the permissions change is unknown.
Posted May 26, 2026 - 08:30 PDT
This incident affects: Applications (Millennium Fast).