Canvas Degraded Performance - 500 Errors

Incident Report for Eastern Oregon University

Resolved

This incident has been resolved.
Posted Nov 22, 2024 - 09:49 PST

Update

Canvas has implemented a fix and all systems are operational. https://status.instructure.com/
Posted Nov 22, 2024 - 09:47 PST

Update

We are continuing to investigate this issue.
Posted Nov 22, 2024 - 09:46 PST

Investigating

Canvas Engineers are currently investigating the issue
Posted Nov 22, 2024 - 09:37 PST
This incident affected: Applications (Canvas LMS).