Laserfiche Forms Not Progressing

Incident Report for Eastern Oregon University

Resolved

This incident has been resolved.
Posted May 27, 2025 - 13:17 PDT

Investigating

Laserfiche Forms are not progressing through workflows as expected. EOU IT is investigating the issue.
Posted May 27, 2025 - 11:36 PDT
This incident affected: Applications (Laserfiche Forms).