EOU Internet Down

Incident Report for Eastern Oregon University

Resolved

Power and internet systems are now stable.
Posted Oct 15, 2025 - 08:35 PDT

Monitoring

Power has been restored and EOU campus internet is connected again.

We will continue to monitor and provide updates.
Posted Oct 15, 2025 - 07:35 PDT

Identified

During scheduled power-testing, the equipment that connects EOU to the internet unexpectedly went offline.

EOU campus currently has no internet access until the issue is located and power is restored.

We are actively working on the issue.
Posted Oct 15, 2025 - 06:57 PDT
This incident affected: Network (Wi-Fi, On-Campus Building Network, Internet Provider (LinkOregon), Telephone).