Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 28, 2025 - 16:00 PDT
Update
Correction: the maintenance will affect the SECOND floor of the WEST wing of Badgley Hall.
Posted Jul 23, 2025 - 17:51 PDT
Scheduled
Network maintenance has been scheduled.
During the maintenance, network service in the following locations may be disrupted briefly: * Badgley Hall, Second Floor, West Wing - All wired Network Services (Ethernet, Telephones)
Note: The EOU and EOU-Guest WiFi networks will not be affected by this maintenance.
Updates will be posted as more information becomes available.
Posted Jul 23, 2025 - 17:47 PDT
This scheduled maintenance affected: Network (On-Campus Building Network, Telephone).