College Scheduler Down
Incident Report for Eastern Oregon University
Resolved
The cause of the College Scheduler outage has been found and remedied.
Posted Feb 10, 2023 - 15:14 PST
Investigating
College Scheduler Down: EOU's College Scheduler tool is not currently functioning properly. We are working with Civitas to investigate the cause.
Posted Feb 10, 2023 - 11:58 PST
This incident affected: Applications (College Scheduler).