Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2024 - 16:00 PDT
Scheduled
We will be deploying changes to the sync to improve timing and loading of historical data. The changes will be addressing Case 200689 Case 200667 Case 200690
Posted Jun 24, 2024 - 15:56 PDT
This scheduled maintenance affected: IS Data Syncs (EOU Slate Success Module).