The issue has been resolved. Anyone still experiencing network issues should contact the IT Helpdesk for a resolution.
Posted Aug 14, 2024 - 12:11 PDT
Investigating
Some campus network equipment in Badgley Hall did not come back online properly following the power shutdown this morning. It appears only parts of the east wing of the building are affected at this time. IT is investigating and will provide further updates as they become available
Posted Aug 14, 2024 - 08:20 PDT
This incident affected: Network (On-Campus Building Network).