EOU's my.EOU.edu portal not displaying cards properly.

Incident Report for Eastern Oregon University

Resolved

Ellucian has updated the status to resolved since no new occurrences happened over night.
Posted Dec 12, 2025 - 09:06 PST

Monitoring

Ellucian has identified the issue and deployed a fix. They will continue to monitor the system to ensure the problem is fully resolved.

Unfortunately, homepage bookmarks cannot be restored. You will need to re-save your preferred cards. We understand this is inconvenient, and we’re sorry for the extra effort required.

For those curious about the cause: bookmarks function as shortcuts to specific cards. When those cards were temporarily removed, the associated shortcuts were lost as well. The cards now visible are new instances, identical in appearance and function, but not the same items you originally bookmarked.

We will also continue to monitor the situation to ensure the problem is actually fixed.
Posted Dec 11, 2025 - 14:48 PST

Investigating

EOU's main portal at my.EOU.edu is currently not displaying cards properly. For now, users may have intermittent access to their cards by using the "All Cards" tab in the portal.
This issue is due to a problem with the Ellucian company's Experience platform. Ellucian is aware of the issue and working on it. Please see Ellucian's status page for any available specifics. https://status.elluciancloud.com/
Posted Dec 11, 2025 - 09:02 PST
This incident affected: Servers & Services (my.EOU Portal).