Canvas is in Full Recovery

Incident Report for Eastern Oregon University

Monitoring

Root issue is Amazon Web Services : https://health.aws.amazon.com/health/status
Oct 20 12:11 AM PDT We are investigating increased error rates and latencies for multiple AWS services in the US-EAST-1 Region. We will provide another update in the next 30-45 minutes.

Oct 20 7:14 AM PDT We can confirm significant API errors and connectivity issues across multiple services in the US-EAST-1 Region. We are investigating and will provide further update in 30 minutes or soon if we have additional information.
Posted Oct 20, 2025 - 07:16 PDT

Investigating

Posted Oct 20, 2025 - 06:57 PDT
This incident affects: IS Data Syncs (EOU Canvas Sync) and Applications (Canvas LMS).