Partial outage: Mountie Portal my.eou.edu

Incident Report for Eastern Oregon University

Resolved

The Mountie Portal issue with cards not loading properly has been resolved.
If you are still experiencing an issue, it is likely that you need to clear your browser cache to allow your browser to find and use the fix.
If you need instructions about how to do this, please read EOU's knowledge base article "How to clear your browser cache" available at this URL: https://eou.my.site.com/s/article/how-to-clear-your-browser-cache-v13
Posted Aug 06, 2025 - 10:42 PDT

Monitoring

The fix for the issue has been implemented, and users should see services working normally again.
If you are still experiencing an issue, it is likely that you need to clear your browser cache to allow your browser to find and use the fix.
If you need instructions about how to do this, please read EOU's knowledge base article "How to clear your browser cache" available at this URL: https://eou.my.site.com/s/article/how-to-clear-your-browser-cache-v13
Posted Aug 06, 2025 - 09:59 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2025 - 09:28 PDT

Investigating

We are investigating reports that some or all cards in the Mountie portal ( my.eou.edu ) are not loading properly. We are working with the service provider for the portal to discover the cause of the issue and will provide updates via EOU's status page ( status.eou.edu/ ) as they are available.
Posted Aug 06, 2025 - 09:17 PDT
This incident affected: Servers & Services (my.EOU Portal).