Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2026 - 06:00 PDT
Scheduled
We are performing routine maintenance on the server that hosts the library.eou.edu website.
During this maintenance window, the library.eou.edu website will be unavailable. Users attempting to access the site during this time will be presented with a "site under maintenance" page.
All services are expected to be fully operational by 8:00 AM (PST).
Posted Jun 22, 2026 - 12:30 PDT
This scheduled maintenance affected: Servers & Services (EOU Library Website).