The My.EOU Portal is being affected by an nationwide performance hit.

Incident Report for Eastern Oregon University

Resolved

No further issues have been observed since the last update. As no further issues are anticipated, this matter is now considered resolved.
Posted Aug 18, 2025 - 16:02 PDT

Monitoring

The issue that caused the degraded performance world wide, was identified and corrected at approximately 12. At this time it does look like they fixed the issue. We'll continue to monitor it for the next few hours and marked it as resolved at that time.
Posted Aug 18, 2025 - 13:02 PDT

Investigating

Reports we're receiving is that MANY other schools are having their first day of school, which has caused whole portions of the Internet Clusters that support higher education to crash. The vendor is aware of the issue and has dedicated full resources to correct the outage.
We will provide updates as we know more.

If you're already in, it may continue to work, but you might also start seeing pages not responding, or 504 gateway timeouts (means the server is overwhelmed and can't deliver what you need)
Posted Aug 18, 2025 - 08:50 PDT
This incident affected: Servers & Services (my.EOU Portal).