Telephone Service Outage
Incident Report for Eastern Oregon University
Resolved
The service provider states that the issue has been resolved.
Posted Mar 22, 2021 - 14:41 PDT
Identified
The service provider is aware of a service disruption within their system and is working to resolve the issue. We will monitor their status page for further updates. https://status.noctel.com/
Posted Mar 22, 2021 - 10:50 PDT
Investigating
We are currently investigating a complete outage of the telephone system. Updates will be posted as more information becomes available.
Posted Mar 22, 2021 - 10:47 PDT
This incident affected: Network (Telephone).