Google Calendar Outage
Incident Report for Eastern Oregon University
Resolved
Google appears to have fully resolved the issue at this time, further information can be found on the previously linked status page: https://www.google.com/appsstatus#hl=en&v=issue&sid=2&iid=cc21ebe3962430b2e4ae2b52e3dde98f
Posted Jun 18, 2019 - 10:38 PDT
Identified
It appears Google has fixed the issue for some users at this time, they expect to have it resolved for most accounts within the next hour.
Posted Jun 18, 2019 - 09:50 PDT
Investigating
Google Calendar is currently experiencing a service outage affecting most, if not all users, you can find more information on this status page here: https://www.google.com/appsstatus#hl=en&v=issue&sid=2&iid=cc21ebe3962430b2e4ae2b52e3dde98f

We will pass major updates along here as Google provides them.
Posted Jun 18, 2019 - 09:08 PDT
This incident affected: Google Apps Calendar.