Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 12, 2024 - 17:00 PDT
Scheduled
EOU IT will be updating the Slate Student Success Early Alert form for improvements to the form beginning today at 5pm. Slate Student Success will still be accessible but the form will not submit so please refrain from using it until the maintenance is completed.
Posted Sep 12, 2024 - 12:46 PDT
This scheduled maintenance affected: Applications (Technolutions Slate).