DegreeWorks Outage
Incident Report for Eastern Oregon University
Resolved
We believe we have found and resolved the issue and Degree Works is back up and functioning again, we will continue to monitor it to ensure it remains up.
Posted Mar 25, 2020 - 16:16 PDT
Investigating
We are currently aware of a DegreeWorks Outage. We are looking into it and will update you once we have an update.

Thank you for your patience.
Posted Mar 25, 2020 - 12:26 PDT
This incident affected: Applications (DegreeWorks).