Fast - Student and Student Accounts

Incident Report for Eastern Oregon University

Resolved

Refresh completed at 8:50am.
Posted Feb 18, 2026 - 09:16 PST

Monitoring

Issue was found and refreshes have started
Posted Feb 18, 2026 - 07:38 PST

Investigating

Custom tables failed to refresh at a step. Some reports may not be updated yet.
Posted Feb 18, 2026 - 07:21 PST
This incident affected: Applications (Millennium Fast).