Union County Power Outage

Incident Report for Eastern Oregon University

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 15:04 PDT

Monitoring

Power has been restored and building networks are coming back online. EOU IT is monitoring for potential problems with network equipment coming back online.
Posted Jun 16, 2026 - 14:38 PDT

Investigating

Power is currently out across Union County in Oregon. Due to this, the EOU campus is currently without power. Generators are running and EOU services are still available remotely.
Posted Jun 16, 2026 - 13:59 PDT
This incident affected: Network (Wi-Fi, On-Campus Building Network, Telephone) and EOU Campus Power.