Maintenance Connect Authentication Down
Incident Report for Eastern Oregon University
Resolved
Authentication has been restored. Please refresh your portal browser page before trying to sign in again.
Posted Aug 15, 2024 - 11:20 PDT
Identified
Maintenance Connect (the Facilities ticketing system) authentication is down. We are working with their support to get it restored.
Posted Aug 14, 2024 - 16:30 PDT
This incident affected: Servers & Services (Authentication / Log-On Services).